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Современные методы медицинской диагностики
должны максимально наглядно демонстрировать
результаты исследований пациентов. Среди всех до-
ступных методов медицинских исследований наи-
более обширный объем графических данных можно
получить методом рентгеновской тонкослойной
компьютерной томографии. Тонкослойная компью-
терная томография – вид рентгеновского исследо-
вания, в ходе которого съемка ведется послойно на
разную глубину с заданным интервалом между
слоями. Результат томографии представляет собой
набор двухмерных теневых плоских изображений
продольного сечения человеческого тела. В настоя-
щее время, в клинической практике данный метод
используется широко, однако, на практике врачеб-
ному анализу подвергаются в основном плоские
изображения продольных сечений человеческого
тела, трехмерная реконструкция используется
редко. При этом трехмерная интерпретация резуль-
татов имеет явные преимущества, но прежде всего
повышает точность и скорость постановки диаг-
ноза. Стандартные методы трехмерной реконструк-
ции, заложенные в программное обеспечение,
поставляемое с оборудованием для томографии,
имеют ограниченные возможности. Целью исследо-
вания является поиск возможного расширения воз-
можностей объемной интерпретации результатов
томографии другими доступными программными
средствами. В статье предлагается алгоритм обра-
ботки изображений, полученных тонкослойной
компьютерной томографией, который включает в
себя следующие операции: настройка контраста,
бинаризация, фильтрация, инверсия, визуализация,
корректировка и расчет. Предложенный алгоритм
позволяет повысить информативность метода тон-
кослойной рентгеновской компьютерной томогра-
фии через построение аксонометрического
(трехмерного) изображения внешних контуров
бронхиального дерева человека, максимально соот-
ветствующих реальным анатомическим парамет-
рам в натуральную величину, без экспериментов с
вмешательством, то есть неинвазивно.
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дицинская диагностика, обработка изображений, лег-
кие, дыхательная система, бронхоскопия,
бронхиальное дерево, трехмерное моделирование, ви-
зуализация, анатомия.

SUMMARY

THE ALGORITHM OF IMAGE PROCESSING OF
THIN LAYER COMPUTED TOMOGRAPHY FOR
CREATING THREE-DIMENSIONAL MODEL OF

THE HUMAN BRONCHIAL TREE OUTER 
CONTOURS

A.M.Ignatova

Institute for Labor Safety, Production and Human of
Perm National Research Polytechnic University, 

29 Komsomolsky Ave., Perm, 
614990, Russian Federation

Modern medical diagnostic methods must demon-
strate the results of patients’ examination to the full ex-
tent. Among all available medical research methods
most extensive amount of image data can be obtained
by X-ray thin-layer computer tomography (CT). Thin-
layer CT is a type of X-ray examination, during which
the recording is done layer by layer at different depths
with a predetermined interval between the layers. The
result is a set of two-dimensional shadow flat images of
the longitudinal cross section of a human body. Cur-
rently in clinical practice, this method is used widely,
however, in certain medical practice only flat longitu-
dinal sections of the image of the human body are ana-
lyzed; a three-dimensional reconstruction is rarely
used. But this three-dimensional interpretation of the
results has a clear advantage, and primarily increases
the accuracy and speed of diagnosis. Standard methods
for three-dimensional reconstruction, built into the soft-
ware that comes with the equipment for tomography,
have a limited capacity. The aim of this study is to
search for possible broadening of opportunities of vol-
umetric interpretation of the results with other avail-
able imaging software. The article suggests an
algorithm of image processing received with the thin
layer CT which includes the following steps: setting the
contrast, binarization, filtering, inversion, imaging, cor-
rection and calculation. The proposed algorithm can
improve the information content of the method of thin
layer X-ray CT through the construction of axonomet-
ric (three-dimensional) images of outer contours of the
human bronchial tree similar to real life-size anatomical
parameters  without intervention, that is to say, nonin-
vasively.

Key words: computed tomography, medical diagnos-
tics, image processing, lungs, respiratory system, bron-
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choscopy, bronchial tree, three-dimensional modeling, vi-
sualization, anatomy.

Среди современных методов медицинской диагно-
стики, которые используются в научных и клинических
исследованиях, наибольшую популярность имеют те
из них, которые позволяют максимально точно и под-
робно визуализировать полученные данные [2, 3]. Для
исследования легких, трахеи и бронхиального дерева
классическими визуализирующими методами яв-
ляются рентгенография, флюорография, бронхоскопия
и рентгеноскопия [1]. Несмотря на обширность полу-
чаемых визуальных данных, использовать их для по-
строения реалистичных трехмерных расчетных
моделей дыхательной системы человека удается только
частично, как правило, с их помощью получают сведе-
ния о величине сечений и углов, которые затем исполь-
зуются в ручном построении упрощенных моделей [5,
10, 12]. Известен [10] опыт получения более точных
моделей бронхиального дерева, параметры, которых
максимально соответствуют параметрам живого орга-
низма, методом заливки полимерной жидкости в дыха-
тельную систему лабораторных животных и
последующего извлечения полученных отливок. Оче-
видный недостаток такого метода – невозможность
проведения многократных экспериментов на одной
подопытной особи и, разумеется, невозможность про-
ведения таких исследований на человеке. Математиче-
ских моделей дыхательной системы человека с
детализацией, соответствующей реальной анатомиче-
ской, в настоящее время не предложено. С 1994 года в
клинической практике используется тонкослойная ком-
пьютерная томография [6]. Данный метод является ин-
формативным, однако использование данных
томографии для трехмерного моделирования дыхатель-
ной системы в настоящее время остается технически
ограниченным. 

Актуальной задачей является расширение возмож-
ностей интерпретации результатов компьютерной то-
мографии через создание трехмерных
(аксонометрических) моделей бронхиального дерева
человека неинвазивным путем (без экспериментов со
вмешательством), которые в дальнейшем были бы ис-
пользованы для создания искусственных легких, изуче-
ния оседания мелкодисперсных частиц пыли в легких,
изучения действия лекарственных аэрозолей и ингаля-
ций, изучения работы альвеол через модель пороупру-
гой среды.

В настоящей работе представлен алгоритм обра-
ботки изображений тонкослойной компьютерной томо-
графии для создания трехмерной модели внешних
контуров бронхиального дерева человека неинвазивно
в реальных условиях и натуральном масштабе.

Известно, что компьютерная томография [7] – это
рентгеновское исследование, в ходе которого съемка
ведется послойно с заданным интервалом между
слоями. Результат томографии представляет собой
набор двухмерных теневых плоских изображений про-
дольного сечения человеческого тела (рис. 1). Степень
контрастности изображений зависит от исследования,

например, пациенту могут вводить специализирован-
ные рентгенконтрастные препараты, и от режимов то-
мографирования. В работе использованы снимки,
полученные при исследовании грудной клетки паци-
ента на томографе марки GE Brightspeed Elite.

Рис. 1. Рентгеновский снимок продольного разреза,
полученный методом тонкослойной компьютерной то-
мографии.

Стандартное программное обеспечение DICON, по-
ставляемое с томографами, как правило, редко исполь-
зуется врачами-клиницистами для трехмерной
реконструкции или «виртуальной» бронхоскопии. В
большинстве случаев специалисты предпочитают про-
водить диагностику, пользуясь плоскими изображе-
ниями, опираясь при их анализе на свой практический
опыт и существующие стандартные протоколы иссле-
дований [4], которые трехмерных визуализаций не
предполагают.

Для обработки изображений тонкослойной компью-
терной томографии можно использовать лицензионное
и бесплатное программное обеспечение. Среди суще-
ствующих программных продуктов, позволяющих бы-
стро и достоверно обрабатывать большие объемы
визуальных данных с минимальными техническими
средствами, наиболее универсальным является про-
граммный продукт ImageJ-FiJi, созданный на основе
языка программирования Java Script. 

Для корректного отображения данных томографии
следует использовать режим «Stacks». Этот режим поз-
воляет, используя данные о последовательности сним-
ков, сразу расположить их в правильной
последовательности.

Алгоритм работы над изображением представлен в
виде схемы (рис. 2).

На начальном этапе обработки изображений сле-
дует воспользоваться функцией настройки масштаба
изображения, для этого используется следующая
последовательность: Analyze→Set Scale, она позволяет
задать корректное соотношение реального геометриче-
ского размера и размера пикселя на изображении. Для
этого предварительно измеряется расстояние в пиксе-
лях на изображении и затем они сопоставляются с ре-
альной величиной этого расстояния на рентгеновском
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топографическом снимке. Современное оборудование
для томографии, как правило, использует масштаб, при

котором один пиксель соответствует 0,8-1 мм реаль-
ного масштаба изображения.

Рис. 2. Алгоритм обработки изображений компьютерной томографии в программе ImageJ-FiJi (Java Script) для
создания трехмерной модели бронхиального дерева. 

Следующие действия, которые следует произвести
над изображением, это его настройка с помощью гра-
фического инструмента «настройка уровней контраст-
ности». Для этого используется функция «уровни» –
Image→Adjust→Threshold (рис. 3 а), такая настройка
позволяет удалить с изображения информацию о дру-
гих органах и системах, и оставить из графических
данных те, которые необходимы для графической об-
работки. 

После этого результат обработки изображения уже
можно подвергнуть трехмерной визуализации с помо-
щью дополнительного пакета «3D Viewer» [11]. Резуль-
тат такой обработки представлен на рисунке 3 б, это
изображение представляет собой модель легких в мо-
мент вдоха. Вращение такой модели, например, позво-
лит увидеть давление ребер на внешние стенки легкого
и оценить участок соприкосновения легких с диафраг-
мой.

Для последующего извлечения из изображения
(рис. 3 а) непосредственно вида бронхиального дерева,
изображение следует перевести в бинарный вид с по-
мощью функции Binary. Затем производится корректи-
ровка изображения с последовательным
использованием инструментов: Process→Binary→
Voronoi; Process→Filters→Variance 3D; Image→Ad-
just→ Threshold. При совместном использовании дан-
ные инструменты позволяют получить послойное
контрастное изображение бронхиального дерева (рис.
3 в). 

Параметры пакета «3D Viewer» заданы таким обра-
зом, что темные участи изображения воспринимаются
как пустоты, следовательно, при обработке такого
изображения пакетом результат будет неудовлетвори-
тельным.

Для того чтобы получить модель, отображающую
внешние контуры бронхиального дерева, изображение
следует инвертировать операцией Image→Invert (рис.

3 г). Результат обработки с помощью дополнительного
пакета «3D Viewer» после инвертирования представлен
на рисунке 3 д. 

Получить изображения модели в разных сечениях
и проекциях можно используя пакет «Volume Viewer»
[12] (рис. 4).

В последующем, трёхмерная модель бронхиального
дерева может быть обработана при помощи инстру-
мента Analyze→3D Object Counter и Analyze→Analyze
Particles, результаты таких подсчетов могут быть пере-
даны в наиболее универсальный программный продукт
для простой обработки массива арифметических дан-
ных MS Excel.

Наиболее интересные данные можно получить при
использовании функции Analyze→Analyze Particles.
Данная функция подсчитывает количество плоских
объектов на каждом слое трехмерного изображения.
При известной величине толщины слоя математиче-
скими операциями могут быть вычислены следующие
величины: объем бронхиального дерева, площадь по-
верхности бронхиального дерева, число отдельных эле-
ментов в реконструкции и средний размер диаметра
бронхиального канала. Пример таких расчетов пред-
ставлен в таблице.

Таким образом, настоящей работой показано, что
информативность метода тонкослойной компьютерной
томографии может быть расширена при использовании
ее изображений для трехмерной интерпретации резуль-
татов. Представлен алгоритм обработки изображений
тонкослойной компьютерной томографии, позволяю-
щий получить аксонометрическое (трехмерное) изоб-
ражение внешних контуров бронхиального дерева
человека, максимально соответствующих реальным
анатомическим параметрам в натуральную величину,
без экспериментов с вмешательством, то есть неинва-
зивно.
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Рис. 3. Обработка изображений компьютерной то-
мографии для построения трёхмерной модели:

а – настройка уровня контраста; 
б – трехмерная модель легких; 
в – изображение после фильтрации;
г – изображение после инверсии; 
д – трехмерная модель.

Таблица
Математический анализ результата трехмерной реконструкции по изображениям 

тонкослойной компьютерной томографии

Объем бронхиального 
дерева, мм3

Площадь поверхности
бронхиального дерева, 

мм2

Число отдельных 
элементов в 

реконструкции, шт.

Средний размер диаметра
бронхиального канала, 

мм

111480 350058,2 20468 5,42
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а б
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Рис. 4. Трёхмерная модель бронхиального дерева человека: а – сечение z/y; б – сечение z/x; в – разворот 30º; г
– угловое сечение. 
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